Windowbox.me - Forums

Improving your desktop experience

Forum Index | Project [ WindowBox | MultiWall | Img2tab | AuzenMixer ]

Auto Cycle Still Not Working

Report or discuss any bugs that you might encounter

Auto Cycle Still Not Working

Postby Patman27 on Tue Mar 18, 2014 3:33 am

Hi guys,

MultiWall has been a great piece of software for my multi-monitor setup, thanks to the deep configuration and recall abilities. Since I've been prompted with a flurry of program updates (many of which have been related to the Crawler or Auto Cycle), I figure I'd chime in since I haven't noticed any improvement on this feature since the first time I installed this software about a year ago.

On my setup (running Windows 7 x64 SP1), Auto Cycle has never worked. I can select one of the preset crawler URLs, and if I select "Crawl" it will find a few images to fill a "queue". I can select any of these images as a background manually, but turning Auto Cycle "On" causes the "queue" to go blank (as if the crawled images have to be re-found) and refuse to refresh. The first image in the series is applied as a wallpaper automatically, but despite multiple cycles of the Auto Cycle timer, it never changes automatically.

I don't find this a deal breaker by any means, since I tend to stick to a wallpaper for a while before deciding to change it. Hope this helps for those that want it, though.
Patman27
 
Posts: 1
Joined: Tue Mar 18, 2014 3:15 am

Re: Auto Cycle Still Not Working

Postby sumo on Wed Mar 19, 2014 4:24 am

The auto-cycle feature uses the crawler in order to get its images, it queues as many wallpapers as you have monitors and then stops the crawler and uses the images, hence why 'it goes blank'. So one downside of this is that you can't really use the crawler separately, They really ought to be split.

As you point out, the images found during the crawl (if auto-cycle is running) will immediately be applied as your wallpaper as part of the auto-cycle system.

'It never changes automatically' - When the auto-cycle timer elapses, the crawler should run and subsequently apply wallpaper. When crawling the web as part of the auto-cycle though, Date order for example cannot be determined without crawling the entire site, this is not really a great idea so the auto-cycle will only take the first image found (for n desktops), stop crawling, and then apply it. That means that if the crawler procures the same wallpaper in the same order from the website over and over again, then it will seem like the wallpaper never changes since its getting the same ones.

Is it possible that the issue you are seeing is this? or do you think that its something else and is not working.

Perhaps it might be a good idea to crawl the entire site and ordering them by date before applying them, but I believe there were issues (like infinite content websites, or having to crawl too much just to change wallpaper, since it has to download them all to determine quality).
User avatar
sumo
Site Admin
 
Posts: 126
Joined: Mon Jul 25, 2011 7:02 pm


Return to MultiWall Bugs

Who is online

Users browsing this forum: No registered users and 1 guest

cron

© Sumeet Patel 2011 Legal